Login to Relay
Incident Report for BlueJeans by Verizon
Resolved
We have resolved issues regarding Relay.
Posted Feb 25, 2020 - 09:40 PST
Update
We are continuing to work on a fix for this issue.
Posted Feb 25, 2020 - 08:38 PST
Identified
The issue has been identified and a fix is being implemented.
Posted Feb 25, 2020 - 08:24 PST