UK dial-in number not working
Incident Report for BlueJeans by Verizon
Resolved
A fix is in place and the issue has been resolved.
Posted May 22, 2023 - 14:00 PDT
Investigating
We are currently investigating reports of UK dial-in numbers not working. Please use alternate dial-in numbers to join your meetings.
Posted May 22, 2023 - 01:30 PDT