UK Support number (+44 800 014 8214) not working
Incident Report for Blue Jeans Network
Resolved
This incident has been resolved.
Posted Nov 07, 2019 - 13:01 PST
Identified
BlueJeans team acknowledges the UK support number (+44 800 014 8214) is not functional at this time. User will get a message "mailbox full". As an alternative please reach out to support via chat or web cases.

https://support.bluejeans.com/s/contactsupport

BlueJeans team is working on mitigating the issue and will provide regular updates.
Posted Nov 07, 2019 - 00:37 PST