Germany Toll Free Numbers
Incident Report for BlueJeans by Verizon
Resolved
The German numbers are now operational
Posted Jun 11, 2020 - 00:38 PDT
Update
We are continuing to work on a fix for this issue. Meanwhile please use +49-69255114416 ( Toll Number , Frankfurt) and +49-32221091256 ( Toll Number, National)
Posted Jun 10, 2020 - 22:44 PDT
Identified
We have identified problems dialling into our German Toll Free Numbers 49-8000007870 and 49-8007244922. We are actively working with our PSTN provider to get this fixed at the earliest.
Posted Jun 10, 2020 - 22:13 PDT
This incident affected: BlueJeans PSTN (Dial-in Phone Number).