BlueJeans Support Site Temporarily Unavailable - https://support.bluejeans.com
Incident Report for BlueJeans by Verizon
Resolved
The Incident has been resolved.
Posted Nov 06, 2019 - 14:55 PST
Investigating
We are investigating issues with accessing our Support Help Center. If you need to submit a ticket, then please call our Support Team at +14087912830.
Posted Nov 06, 2019 - 11:50 PST
This incident affected: Web Access to bluejeans.com pages.