Intermittent failures for PSTN users from UK
Incident Report for BlueJeans by Verizon
Resolved
This incident has been resolved.
Posted Oct 20, 2020 - 08:13 PDT
Monitoring
The PSTN numbers in UK are now working and we are currently monitoring.
Posted Oct 19, 2020 - 17:02 PDT
Update
We are continuing to investigate PSTN dial in issues impacting a subset of users in UK. Please use the following numbers: "+44.141.483.6502" or "+44.203.976.1937" to dial into your meetings.

The team is continuing to work on mitigating the issue with other UK numbers.
Posted Oct 19, 2020 - 11:43 PDT
Update
We are currently investigating dial in issues with certain PSTN numbers in the UK. Please use the following numbers: "+44.141.483.6502" or "+44.203.976.1937" when dialing into your meeting.
Posted Oct 19, 2020 - 08:48 PDT
Investigating
BlueJeans team acknowledges an incident related to subset of user in EMEA region unable to connect to BlueJeans meeting via PSTN dial in. We are working towards mitigating the issue, as a workaround please join your BlueJeans meetings via Blue App or WebRTC.
Posted Oct 19, 2020 - 07:51 PDT
This incident affected: BlueJeans PSTN (Dial-in Phone Number).