Scheduling with O365
Incident Report for Blue Jeans Network
Resolved
This incident has been resolved.
Posted about 1 month ago. Jun 15, 2019 - 02:30 PDT
Update
Microsoft has acknowledged the issue and is working on addressing it. Updates are available for Microsoft admins in https://portal.office.com/AdminPortal/Home
Posted about 1 month ago. Jun 14, 2019 - 12:09 PDT
Identified
Some O365 users are experiencing issues with O365 plugins and BlueJeans is also impacted by this. We are working with Microsoft to resolve this as soon as possible. Please use our web app to schedule any meetings.
Posted about 1 month ago. Jun 14, 2019 - 11:14 PDT