BlueJeans Store Email
Incident Report for BlueJeans by Verizon
Resolved
It was confirmed that this was an email from BlueJeans that was sent in error. We apologize for any concerns this has raised and the issue has been corrected.
Posted Oct 13, 2021 - 09:57 PDT
Investigating
We have received reports of customers receiving an email from store@bluejeans.com. We are currently investigating and will update once we have more information.
Posted Oct 13, 2021 - 09:37 PDT