BlueJeans Service Disruption- Call Drops
Incident Report for BlueJeans by Verizon
Resolved
This incident has now been resolved.
Posted Mar 19, 2020 - 15:28 PDT
Investigating
A small subset of users may have experienced call drops at around 2:38pm PDT. Rejoining the call addressed the issue.
Posted Mar 19, 2020 - 14:38 PDT