Brazil PSTN Number
Incident Report for BlueJeans by Verizon
Resolved
The Brazil number is now operational.
Posted May 27, 2020 - 22:00 PDT
Identified
We have identified problems dialing into our Brazil Toll Free Number- +55.11.3958.7770 and are actively working with our PSTN provider to get this fixed at the earliest.
Posted May 27, 2020 - 09:00 PDT