Command Center- Past meetings
Incident Report for BlueJeans by Verizon
Resolved
This incident has been resolved.
Posted May 05, 2020 - 16:05 PDT
Identified
Past meetings data is delayed by up to 15 minutes and our team is working on it.
Posted May 05, 2020 - 09:00 PDT
This incident affected: Command Center.