Issues accessing support link - https://support.bluejeans.com/
Incident Report for BlueJeans by Verizon
Resolved
This incident has been resolved.
Posted Oct 25, 2019 - 10:59 PDT
Investigating
Our team is currently working with the host provider to get this fixed. Please use +14087912830 to call our support team for any issues or assistance needed.
Posted Oct 25, 2019 - 08:54 PDT
This incident affected: Web Access to bluejeans.com pages.